Fandom

Scratchpad

UMP-cPL: FAQ

215,803pages on
this wiki
Add New Page
Discuss this page0 Share

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.


Pytania i odpowiedzi

czyli co warto wiedzieć, żeby nie odkrywać Ameryki na nowo, albo żeby się nie wygłupić.



Część dla początkujących

Nic nie wiem, a chciałbym przyjrzeć się tej mapie!

Czy masz program Mapsource? Nie? to ściągnij dowolne demo, i zainstaluj. I już masz.

Masz Linuksa? Pod nim też można sobie poradzić, choć z małymi sztuczkami.

Masz Mac'a? Pod MacOSX działa już wiele produktów Garmina. Bobcat, czyli MapSource dla MacOSX, pozwala na oglądanie map i edycję POI oraz tracków. Map Install pozwala zainstalować specjalnie przygotowaną wersję UMP-pcPL dla Macos w odbiorniku.

Już masz? to ściągnij program instalacyjny naszej mapy do MapSource (ump-pcpl-setup.exe) z tej strony, zamknij Mapsource, i zainstaluj. Poprawki ściągać będziesz przez ikonkę, która pojawiła Ci się na pulpicie Windows. Uwaga - jeśli ikonka ściąga wersję nie-NT (tak było w starych instalacjach), to edytuj w niej linie 9 i 10, łatwo zgadniesz o co chodzi.

Nie chcesz całego wielkiego Mapsource? Ściągnij MapEdit (tylko PC/Win, działa pod wine, shareware, 610kB). Rozpakuj exe do jakiegoś katalogu (nie wymaga instalacji). Ściągnij któryś [update plik (img) mapy], albo całość i rozpakuj. Uruchom rozpakowany mapedit.exe i otwórz któryś z plików img (numery są na wzór "kierunkowych" w telefonach). Miłego przyglądania się. Raczej nie zmieniaj plików img – niewiele pożytecznego z tego wyjdzie. Chcesz obejrzeć w odbiorniku, a jeszcze go nie masz? Jeśli dopiero zaczynasz, i nie wiesz co naprawdę by Ci pasowało, jeden z naszych sympatyków miewa różne odbiorniki, i chętnie je pożyczy na próby (i odbiornika, i różnych map) w terenie, za skromną pracę na rzecz mapy UMP. Poczytaj tutaj.

No dobra, chcę obejrzeć więcej, tu mam odbiornik, a tu kompa.

Najprościej – gdy UMP masz "wgranego" pod Mapsource. Wtedy przesyłasz i już. Bywa, że nie chce Ci się dłubać, albo nie masz Mapsource. Do wgrywania pojedynczych img służy Sendmap – szukaj na stronie (wersja windowsowa lub linuksowa, obie darmowe). Jeśli masz sprzęt z kartą pamięci, to odpowiedni plik do wgrania na nią wygenerujesz tym samym Sendmapem z opcją -l (i lista plików img). Cała nasza UMP-pcPC jest gotowa do ściągnięcia z tej strony - plik GMAPSUPP.IMG NT. Wgraj ten plik do katalogu Garmin na karcie.

Mam nuvi, wgrywam Waszą mapę, wyszukuję – a tu pytanie o województwo, i nic do wyboru.

Ściągnąłeś wersję nie-NT. Nuvi takich nie rozumie. Wykaz dostępnych wersji masz tutaj.


Zauważyłem coś nie teges. Jak Wam to zapodać?

Poinformuj nas o tym w systemie zgłoszeniowym ewentualnie skontaktuj się emailem. System zgłoszeniowy dostępny pod adresem http://ump.fuw.edu.pl/flyspray/ jest obecnie zalecaną formą zgłaszania wszystkich poprawek.

Póki się w nim nie zarejestrujesz, możesz zgłaszań poprawki anonimowo, natomiast po rejestracji masz większe możliwości śledzenia, co się z twoimi poprawkami dzieje dalej. Każda ze zgłaszanych poprawek otrzymuje specjalny numer i można śledzić, czy i kiedy została wprowadzona do mapy. Jeśli poprawka jest niekompletna lub niejasna i wymaga wyjaśnień, także możesz to sprawdzić śledząc ją na stronie WWW, albo zaznaczając w konkretnym zgłoszeniu, że chcesz być automatycznie informowany emailem, gdy ze zgłoszeniem coś się dzieje – np. zostało zaimplementowane częściowo lub w całości, albo gdy wymagane są wyjaśnienia.

W jaki sposób przygotowujesz dane do poprawienia, zależy już tylko od Ciebie – staramy się przyjmować wszystko, ale jeśli w przygotowanie poprawek włożysz trochę czasu, by były one jasne i (najlepiej) zawierały ślady/punkty w załącznikach, to poprawki zostaną zaimplementowane zdecydowanie szybciej.

Plan minimum: napisz "po ludzku" co jest złe (w mieście X ulica A nie dochodzi do B bo tam jest chodnik, albo ulicę C przedłużono asfaltem do ulicy D). Żeby dokładnie pokazać miejsce, możesz postawić w Mapsource punkt(y), i zapisać je jako plik gdb. Albo zrobić obrazek. Jeśli możesz, albo jeśli to bardziej pusty teren, podeślij traki (ważne! wyłącz przyciąganie do drogi! uwaga, niektóre odbiorniki tego nie potrafią – wtedy możesz wyłączyć mapę na czas rejestracji śladu; dobrze też przestawić sposób rejestracji z automatycznego na "co 1 sekunda", bo tamten na zakrętach czasem zbytnio upraszcza) i/albo waypointy stawiane na skrzyżowaniach. Jeśli stawiasz punkty, to zapisuj sobie od razu, co który znaczy, bo po kilku dniach sam się w tym pogubisz. W roli notatnika dobrze sprawdza się dyktafon w komórce.

Uwaga – prosimy zaznacz (najlepiej w temacie) z jakiego obszaru są podsyłki, a na maila nie podsyłaj plików większych niż kilkanaście kB. No i podpisz się, i dodaj email kontaktowy. Inaczej nie będziemy mogli ogłosić Cię jako Współpracownika.

Plan średni: podeślij traki (gdb ewentualnie plt) z jeżdżenia w kratkę / w grzebień (waypointy z nazwami ulic mile widziane, także jakieś opisy co to i dlaczego).

Plan wypas: czytaj dalej to FAQ :)


A kto to jest ten ump@ ?

To zwykła emailowa lista dystrybucyjna. Wyślesz na nią sensowny list – dostaną go wszyscy uczestnicy naszego projektu.

Jeśli jesteś zainteresowany uczestnictwem w życiu wewnętrznym, możesz się dopisać (ale pamiętaj, że często bywają tam nudne dla "niezaangażowanych" dyskusje techniczne, albo raporty o błędach – więc nie zaczynaj od zapisania się).Wyślij list do kierownika (czyli zarządcy list), napisz magiczną formułkę "subscribe ump". Albo help. Wypiszesz się podobnie (unsubscribe).

Jeśli coś Ci nie wychodzi, to po prostu odpuść chwilowo ten punkt.


Jak pracować tak na serio?

Ściągnij źródła (moduły narzedzia oraz któryś z UMP-miasto). Z folderu narzedzia weź plik setenv.bat, skopiuj go "piętro wyżej" (do tego folderu, w którym widzisz narzedzia oraz UMP-miasto), i edytuj go, żeby zmienić ścieżki na Twoje własne lokalne potrzeby. Uwaga – kawałek ścieżki ze spacją zamknij w cudzysłowach:

C:\"Program Files"\ump\cvs

Przed każdym rysowaniem powinieneś uaktualnić dane, które przecież mogły się zmienić przed chwilą:

 Start -> Uruchom -> c:\ump\cvs.exe -d:pserver:guest@ump.waw.pl/home/cvsroot update UMP-Lublin

a jeśli chcesz przeczytać jakieś informacje o efektach:

 Start -> Uruchom -> cmd
 cd c:\ump
 cvs -d:pserver:guest@ump.waw.pl/home/cvsroot update UMP-Lublin

Upewnij się, że w MapEdit opcja "Tools > Options > Snap to grid" nie jest włączona, (Ważne! trzeba to ustawić zanim sie przystąpi do pracy). Uruchom mont-demont w którymś z folderów UMP-*. Jeśli wpisałeś dobre ścieżki, otworzy się MapEdit z odpowiednią mapą.

Rysuj.

  • Nie używaj "Tools – Generate routing graph" (psuje nasze źródła).
  • Na razie nie przejmuj się poziomami.
  • Włącz największe szczegóły (klawisz "zero").
  • Drogi rysyj na zbliżeniu 50-200m, mniejszych (10-30m) używaj do rond, skomplikowanych zakrętów, stawiaj jak najmniej węzłów(nod).
  • Jednokierunkowość zaznaczaj na zakładce "Properties – Has direction", a parametry routingu stosuj tylko wyjątkowo (np. rysujesz deptak czy inne słupki w poprzek ulicy).
  • Zmiany przebiegu dróg rób na podstawie kilku śladów – odbiorniki czasem sie lekko gubią, a czasem mają dziwne stałe przesunięcie, więc lepiej, żebyś był pewny powtarzalności błędu.
  • Jeżeli dodajesz ulice w różnych miastach czy okolicach, zaznaczaj to w komentarzach (pod MapEdit, jeśli dodajesz kilka uliczek w Pcimiu to do pierwszej dopisz "odtąd Pcim", a do pierwszej poza Pcimiem "a teraz miasto takie i takie" – albo wręcz do każdej ulicy z osobna, ogromnie ułatwia to potem porządkowanie przed wysłaniem na serwer).
  • Ulice rysuj tak długimi kawałkami, jak trzeba (nie tnij ich niepotrzebnie na zbyt małe fragmenty), przedłużaj drogi (nie dodawaj króciutkich dróżek).

Uff, gotowe, zamknij MapEdit (oczywiście nagraj zmiany). W folderze pojawiają się Miasto-wynik.mp (to jest ta mapa, którą zmieniałeś), i kilka plików w zależności od tego, co robiłeś, na przykład

 !nowosci.txt 
 !nowosci.pnt
 LUBLIN.drogi.txt 
 LUBLIN.drogi.txt.diff.txt 
 LUBLIN.kolej.txt 
 LUBLIN.kolej.txt.diff.txt

Pliki !nowosci zawiera nowo dodane elementy. Pliki diff pokazują zmiany. Warto je przejrzeć, czy na pewno zawierają te i tylko te obiekty, które zmieniłeś. Dodaj teraz jakiś plik tekstowy, gdzie napiszesz kilka słów co zmieniłeś, i podpiszesz się – żebyśmy mogli odpowiedzieć, wyjaśnić niejasności, zasugerować poprawienie jakichś elementów. Spakuj swój plik z opisem, pliki diff.txt, oraz pliki nowosci, i wyślij nam poprzez system zgłoszeniowy na WWW" (preferowany), ew. emailem.

Po wysłaniu zgłoszenia, możesz już skasować te pliki, które Ci się pojawiły po edycji. Póki nie poczujesz się biegłym, nie wprowadzaj naraz więcej niż kilkanaście zmian – w razie jakiegoś niepowodzenia nie będzie dużo roboty do powtórzenia. Zostało poczekać kilka godzin lub dni na wprowadzenie Twoich danych. Zmiany możesz obserwować na stronie z logiem, a w systemie zgłoszeniowym – śledząc swoje zgłoszenie (albo dopisując się do powiadomień wysyłanych automatycznie, gdy zgłoszenie zostanie poprawione/zamknięte). Możesz przystąpić do rysowania kolejnych rzeczy – skocz na początek tego kroku. A tutaj jest jeszcze bardziej szczegółowy opis konfiguracji i kroków.

Dla ułatwienia startu z naszymi plikami został stworzony startup pack.

A co to są te zielone lub czerwone słupki na mapie w Mapedit?

To są znaczniki używane do sprawdzania mapy przez rysującego – można sobie wygenerować spis ślepych końców (i zauważyć, gdzie droga nie jest dociągnięta do innej), a zielone słupki oznaczają "tak, tu jest koniec, nie alarmuj". Analogicznie – czerwone słupki oznaczają "tak, tu jest wiadukt" i powstrzymują alarmy w przypadku przecinania się dróg bez punktu styku.


Jak ściągać całe źródła?

Utwórz folder (katalog) – na przykład

C:\cvs

Zainstaluj sobie klienta systemu cvs (na przykład WinCVS, albo tekstowy jeden exe) i pobierz aktualny kształt projektu:

 cvs -z5 -d:pserver:guest@ump.waw.pl/home/cvsroot checkout all

(albo zamiast all: UMP-Warszawa, UMP-Zamosc i tak dalej) (z5 – średnia kompresja przesyłanych danych). Pobierz też moduł 'narzedzia'. Jeśli klikasz spod Windows, ale w trybie tekstowym, rób Start -> Uruchom -> wpisz polecenie poprzedzone ścieżką do folderu, który zrobiłes na początku, na przykład

 c:\ump\cvs.exe -z5 -d:pserver:guest@ump.waw.pl/home/cvsroot co UMP-Lublin
 c:\ump\cvs.exe -z5 -d:pserver:guest@ump.waw.pl/home/cvsroot co narzedzia

Jeśli nie pokręciłeś, po chwili w folderze cvs zobaczysz takie podfoldery, jakie ściągnąłeś. W nich będą zwykle folder CVS, folder src, i plik mont-demont.bat. Kolejne poprawki dostaniesz tak: (w tym samym katalogu lub w dowolnym podkatalogu)

 cvs -d:pserver:guest@ump.waw.pl/home/cvsroot update -Pd

Jeżeli skopiujesz plik cvs.exe do c:\windows to będziesz mógł skorzystać z cvs_update.bat w katalogu UMP-Miasto


A co, jeśli mam Pocketa/Mio/itp?

Trzeba poczytać u GPS Maniaka. Jeden z kolegów uzupełnia: Jak zainstalować zwykłe gpsproxy i QUE na PDA można poczytać u GPS Maniaka. Można użyć samego GPSProxy bez QUE do zapisania tracków. Moda GPSProxy 1.16 by wsian można zassać np. z http://www.malsingmaps.com/forum/modules.php?name=Forums&file=viewtopic&t=3345 (to nie jest instalka, trzeba ręcznie skopiować pliki na PDA do jakiegoś katalogu). Moda konfiguruje się tak samo jak zwykłe GPSProxy. Dodatkowo mod pozwala na zapisanie tracków do plików plt. Trzeba tylko zaznaczyć w gpsproxy by wsian opcję "Track Log" na zakładce GPS. Tracki zapisywane są do katalogu do którego skopiowaliśmy pliki GPSProxy by wsian. Po zakończonych wędrówkach wystarczy skopiować tracklog.plt z tego katalogu i otworzyć w np. mapedit.

Hint: jeśli w PDA są ustawienia systemowe ustawione na PL to trzeba przerobić plik wynikowy na format jak poniżej. (zmiana przecinków na kropki).

52.25979,20.89650,0,342,8,0,2006-05-03,11:05:38,6,8m

A tu trochę podpowiedzi, jak mając Automapę być przdatnym dla UMP: AM zarówno 4.0 jak i 3.9 umożliwia zapis tracka (wersji wcześniejszych nie znam więc się nie wypowiem). Trzeba przekopać się przez menu i włączyć odpowiednią opcję.

Dla AM 4.0:

Menu/GPS/włącz zapis śladu (są i inne sposoby, ale ten najłatwiej opisać ;) Podać jakąś nazwę pliku pod jaką track ma zostać zapisany oraz jego lokalizację i zatwierdzić OK'ejem. Że włączony jest zapis można poznać po czerwonym kwadracie w lewym górnym rogu. Żeby zakończyć zapis: Menu/GPS/Zatrzymaj zapis śladu i czerwony kwadrat znika. Tracka można sobie obejrzeć w AM wchodząc do Menu/GPS/Pokaż ślad. Można też się wirtualnie po nim przejechać Menu/GPS/Odtwórz ślad. Track jest zapisywany w plikach *.gps i *.gps.bin. Co jest w *.gps.bin nie mam pojęcia, ale nie jest on potrzebny do konwersji na *.plt (o czym dalej)

Dla AM 3.9:

Włączanie wygląda podobnie. Natomiast sygnalizowanie włączenia zapisu jest zupełnie inne niż w AM 4.0 – w 3.9 jet to czerwona kropka w lewym górnym rogu  :-D Reszta obsługi tak samo jak w AM4.0 Track jest zapisany w pliku *.gps

To co wypluje z siebie AM można przerobić na bardziej cywilizowany format dzięki AmConv. Obsługa programu banalna więc nie będę pisał.

A co, jeśli mam Nuvi/itp?

Kup Vistę. A na serio: głównym problemem jest to, że Twój GPS nie potrafi zapisywać traków (uwaga: o Nuvi 200 patrz na końcu). Możesz wysyłać nam jednak waypointy zapisane w terenie. Aby dodać nowy punkt, zapisz go po prostu w swoim Nuvim, w miarę możliwości dodając opis (adres, numer telefonu etc.). Jeśli chcesz dodać nową nieistniejącą na mapie drogę lub ulicę, zaznacz waypointami jej końce, zakręty itp. Aby wysłać nam punkty zapisane w Nuvim, przekopiuj z odbiornika plik current.gpx, znajdujący się w podkatalogu \garmin\gpx\. Plik ten zawiera wszystkie Twoje waypointy, więc przed wysłaniem go do nas wyrzuć niepotrzebne (prywatne) dane np. przy pomocy MapSource.

Nuvi 200:na Garniaku opisano, jak zbierać nim tracki. Potrzebny jest firmware odbiornika w wersji 3.40. Taki track z pliku gps.bin przerób na format gpx programem www.anpo.republika.pl/download.html#nutrak i sprawdź np. w Mapsource, czy dobrze się przerobił – i podsyłaj.

A co, jeśli mam telefon z symbianem ?

Pod symbiana można używać Garmin Mobile XT.
Zapisywanie traków można włączyć przechodząc do Narzędzia -> Zarz. moimi dan.->Ślady.
Trase należy wyesportować korzystająć z Narzędzia -> Zarz. moimi dan.-> Zarządzaj->Export GPX.
W katalogu garmin/gpx utworzony zostnie pliczek current.gpx. W przypadku polskiej wersji należy jeszcze zamienić wszystkie przecinki w pliku .gpx na kropki i można wysyłać wgrać do map edit.

Co zrobić żeby nie było plików !nowosci?

Jak masz dowolny obiekt (droga, poi, obszar) i jesteś w trybie zaznaczania (po naciśnięciu "S") podwójnie kliknij na nim, pojawią sie właściwości przejdź do zakładki "extras", przycisk "Edit As text" dodaj

Plik=src\plik_z_katalogu_src*

*Jeżeli nie wiesz co tam wpisać zobacz co mają okoliczne drogi/poi. Sugeruje nawet żeby kopiować te dane.

Jeżeli wpisujesz .drogi.txt możesz mu od razu dopiać Miasto, pozwala to na wyszukiwanie ulic w mieście

Miasto=Jakieś_Miasto

Pliki src\MIASTO.ulice.txt automatycznie dostają Miasto=MIASTO przy kompilacji, wiec wpis jest zbędny.

Znalazło mi wirusa w pliku wget.exe!

Jednym ze składników pakietu instalacyjnego jest wget.exe - niewinne narzędzie służące do ściągania plików. Niestety to samo narzędzie wykorzystał autor jakiegoś świństwa i teraz niektóre programy antywirusowe raportują trojana w tym pliku. Podsumowując - nie masz się czym martwić.


UMP Szlaki, Instalacja i Aktualizacja

Na stronie UMP oprócz mamy drogowej można znaleść mapke UMP Szlaki.

Aby z niej skorzystać należy...
Utworzyć katalog C:\Garmin\UMP-szlaki
Rozpakowac plik UMP-szlaki.zip do katologu C:\Garmin\UMP-szlaki
Dodać odpowiednie wpisy do rejstru windows, korzystająć z pliku reg. c:\Garmin\UMP-szlaki\UMP-szlaki.reg

Aktualicja

Następuje poprzez rozpakowywanie kolejnych wersji UMP Szlaki, można również również utworzyć poniższy plik .bat, który zrobi to za nas.

AktualizujSzlaki.bat

del UMP-szlaki.zip
c:\wget\wget.exe http://www.ump.waw.pl/mapy/UMP-szlaki.zip
"C:\Program Files\7-Zip\7z.exe" x -y -o"C:\Garmin\UMP-szlaki\" UMP-szlaki.zip
del UMP-szlaki.zip
pause

Uwaga, aby plik zadziałał, należy mieć zainstalowane programy 7-zip oraz WGet.


end FAQ dla początkujących

Część dla zaawansowanych (developerów)

O czym trzeba pamiętać (na początek, albo po przerwie)?

  • MapEdit (ustawienia – włączone Stick to neighbours; zrezygnowaliśmy ze Snap to grid w połowie lipca 07);
    • najnowszy (tam), szczególnie jeśli dotykamy ulic z numeracją, a jest ich coraz wiecej,
    • michus w specjalnej wersji Rafała Fitta (fitt.tychy.pl/gps/) dla obszaru Wrocławia (zachowuje dokładność 6 miejsc), albo dla ceniących elastyczne przyciąganie. Na pozostałych obszarach także można używać wersji 6-miejscowej, pamiętając jednak o ponownej konwersji na 5 cyfr po przecinku przed wykonaniem "cvs commit" (mont-demont ma do tego opcję "--round", a przejście 5 cyfr -> edycja 6-cyfrowa -> konwersja z opcją --round nie powoduje "migotania" danych)
  • typy do stosowania opisane są w cvs w pliku narzedzia/opisy/UMP-signify.txt
  • stosować mont-demont. Dla uniksowców przygotowany jest w katalogu głównym plik Makefile.common ułatwiający życie – wystarczy ustawić zmienną środowiskową DIR na odpowiednią wartość (np. "setenv DIR UMP-Opole"), a potem "make mont", "make demont")
  • do sprawdzania służy "sprawdz_bledy.bat".


A co z ciekawymi punktami?

Tu chyba nie potrzeba wyjaśnień. Podsyłasz najlepiej w formie:

52.21860, 20.96573, 0,Wietnamski 24h,Aleje Jerozolimskie,Warszawa,ASIAN
52.21851, 20.96428, 0,UP 79,Aleje Jerozolimskie,Warszawa,POCZTA
52.23313, 21.10652, 0,Citi,Ostrobramska,Warszawa,ATM
52.13997, 21.05474, 0,Pierogarnia,Meander,Warszawa,BAR

Typy BAR, POCZTA itd wybieraj z zestawienia. Zwróć uwagę na:

  • spacje – nie za dużo, szczególnie koło nazw i typów
  • w typach stosuj takie małe/DUŻE jak zapisano
  • obojętne który typ z wymienionych w jednym wierszu arkusza Poiologia wybierzesz
  • sugeruję posortować podsyłane rzeczy typami (szpitale i apteki razem, jedzenia razem, itd itd)
  • zaznaczaj, jeśli apteka, sklep itd. są 24h

Rozszerzenie od lutego 2005: po nazwie ulicy możesz (nie musisz, ale prosimy) podać nr domu oraz nr telefonu oddzielone średnikami, a po typie (i przecinku) kod pocztowy, np:

52.19071,  21.01573, 0,Raiffeisen,Al.Niepodleglosci;69;+48 22 5499900,Warszawa,ATM,00-955

W numerze telefonu wszystko inne poza cyframi, spacjami i myślnikami jest zamieniane na myślniki. Zalecany format numeru telefonu to "+48 kk nnnnnnn" gdzie kk to kierunkowy, a nnnnnnn to reszta numeru (w przypadku telefonów komórkowych będzie to oczywiście odpowiednio 3+6 cyfr). Oczywiście można pominąć telefon (ulica - średnik - dom - przecinek - miasto) albo numer domu (ulica - średnik średnik - telefon - przecinek - miasto).

A miasta?

tak:

52.23175, 21.00552, 7, Warszawa

gdzie 7 jest wielkością miasta w umownej skali. Pewnie jak będziecie podsyłać to jakieś małe wioski, więc wielkości 0 lub 1.

Drugie nitki.

To takie miejsca, gdzie asfalty dla przeciwnych kierunków ruchu są przegrodzone trawnikiem, bandą, tramwajami itd – tak że nie można zawrócić (podwójna ciągła się nie liczy :-D ). Fajnie by było, gdyby były rysowanie dwoma kreskami (oczywiście kierunki, DirIndicator, Levels). Na celowniku (w Warszawie) są następujące:

  • Conrada (?)
  • czekamy na zgłoszenia Miłe są informacje zarówno o miejscach (ulica... od... do...), jak i tracki z przejazdów – dobrze gdyby środkowymi pasami i kilka razy.


Co radzi / precyzuje Staszek (gps_mapper) i zdrowy rozsądek?

  • nie stosować nakładania obszarów!!
  • robić obszary tak duże, jak trzeba (nie dzielić sobie na kawałki)
  • jak najmniej punktów w liniach
  • zapomnieć że jest obiekt typu background (na mapie może być tylko jeden, i kompilator dokłada)
  • w Label= obiektów wyszukiwalnych (ulic) nie stosować kodów ~[0x1B] do 1F, można tylko 2A do 2F
  • nie umieszczać obiektów wyżej, niż na poziomie 0, a do pokazywania w oddaleniu stosować EndLevel=


O czym pamiętać wrzucając samemu albo poprawiając?

  • Znajdowalność ulicy w danym mieście wynika z nazwy pliku, w którym ona jest, więc można robić np. oddzielny plik dla Ząbek, a oddzielny dla Zielonki. Pojedyncze ulice (czy też niewielką ich ilość, np. kilkanaście) dowiązuje się do miasta przez dodanie ekstra parametru Miasto=Gdzieśtam.
  • Ponieważ ulice są sortowane po nazwach (przez odbiornik, w celu wyszukiwania), stosuj kolejność tylko nazwisko – nawet, jeśli to głupio wygląda: "Plater", a nie "generała Bema" albo "Józefa Bema" ani nawet "Bema Józefa", "Bema generała" itp. Wyjątki robimy dla 'stałych' połączeń (księcia Janusza, Stanisława Augusta itd. – ale ani Emilii Plater, ani Jana III Sobieskiego)
  • DirIndicator=1 (MapEdit: "Has Direction") tylko dla ulic jednokierunkowych. Jednokierunkowa jest również nitka ulicy wielopasmowej. I tylko tak, a nie parametrem routingu. Pamiętajcie, że dwupasmowe trzeba rysować zgodnie z kierunkiem jazdy, czyli z przeciwnych kierunków. Trzeba odwrócić kierunek? Zrób w ME "reverse polyline" (bo DirIndicator=-1 działa dziwnie).
  • Drogom "ważnym" dajemy jakiś tam wysoki EndLevel, ale tylko jednej nitce – po to, żeby na oddaleniu dwie nitki w odległości jednego piksela nie zlewały się i głupio wyglądały. Druga może być tylko na poziomie 1, ewentualnie 2. Analogicznie, ronda i rampy też można rysować tylko na poziomach od 0 do 1 lub 2 – bo zwykle są za małe, żeby je warto było pokazywać na widoku całego województwa. I jeszcze jeden wyjątek – prowizorki, czyli drogi zrobione "na oko" (aby tylko routing potrafił sensownie przeskoczyć) tylko na poziomie 0.
  • ...


Kody dróg krajowych

bo dokumentacja "ZrUMP to sam" nie jest dokładna: Tylko dla POLYLINE:

  • Label=~[0x2a]012 aa – widać 012 w czarnej tarczy, opis AA, po najechaniu kursorem "I-012 Aa", i tak samo w spisie wyszukiwalnych ulic (wyszukuje się jakby miało nazwę "012 Aa")
  • Label=~[0x2b]123 abc – 123 w tarczy, opis widoczny ABC, po najechaniu "US 123 Abc", i tak samo w spisie
  • Label=~[0x2c]234 bcd – 234 w jajku, opis BCD, po najechaniu i w spisie "Hwy 234 Bcd"
  • Label=~[0x2d]3 cde – 3 w prostokącie z szarymi paskami na górze i na dole, opis CDE, "3 Cde"
  • Label=~[0x2e]45 def – 45 w prostokącie, opis DEF, "45 Def"
  • Label=~[0x2f]567 efg – 567 w jajku, opis EFG, "567 Efg"
  • 2g robi jakieś głupoty ;-)Trzeba stosować: dla dróg jednocyfrowych 2d, dwucyfrowych 2e, trzycyfrowych 2f.

Zrobiłem te numery dróg, ale teraz ich nie wyszukuje, a i routing mi gada nimi, a nie ludzkimi nazwami!

Trzeba zastosować dodatkowe nazwy. Odbiorniki używają:

  • do wyszukiwania – Label (kod nazwa), Label2 (nazwa) i Label3 (nazwainna)
  • do pokazywania na mapie – Label (kod w tarczy i nazwa wzdłuż kreski jeśli się patrzy, albo kod i nazwa jeśli najedzie się strzałką)
  • w routingu – przeważnie Label2, za wyjątkiem ostatniego docelowego odcinka, gdzie gada Label.Więc optymalna definicja ulicy z numerem drogi będzie taka:
[POLYLINE]
Type=0x2
Label=~[0x2b]2/8 Prymasa Tysiaclecia
EndLevel=1
DirIndicator=1
Data0=(52.22660,20.95715),(52.22458,20.95767),...
Label2=Trasa AK
Label3=Prymasa Tysiaclecia
[END]

Uwaga dodatkowa – wyszukiwanie Label działa źle tylko dla ulic z kodami 2a, 2b i 2c (chyba).


Jak zrobić numerację domów?

W MapEdicie :-D

Kiedyś trzeba było kombinować, ale teraz MapEdit wspiera numerowanie, więc wystarcza w trybie 'M' używać prawego klawisza i opisywać węzły na zakładce Numbers. Zaplecze teoretyczne (ale nie musisz tego ogarniać od razu) wygląda tak: na przykładzie ulicy Agrykola zdefiniowanej trzema punktami Data0=(n,s),(n,s),(n,s):

Numbers1=0,o,1,9,e,2,6,-1,-1,-1,-1
Numbers2=1,o,11,21,e,10,44,a2,b2,c2,d2

I odbiornik już wie że mamy: pierwszy odcinek strona lewa (patrząc w kierunku rysowania) to numery domów nieparzyste o(dd) od 1 do 9, prawa parzyste e(ven) od 2 do 6, drugi odcinek odpowiednio od 11 do 21 i oczywiście od 10 do 44

  • literki można ustawić b(oth) i wtedy numerki będą po kolei: 1,2,3... (uwaga: dopiero od kompilatora 0088, wcześniej B), a można n(one), i wtedy w ogóle numerków nie będzie
  • lepiej nie kombinować i stronę parzystą opisywać numerami parzystymi:
Numbers1=0,e,7,11,o,8,26,-1,-1,-1,-1 <- źle<

stronę lewą numeruje od 6 do 10, prawą – od 9 do 27

  • minusjedynki powodują wyświetlanie miasta etc tak jak jest "odgórnie"; jeśli numerki będą zdefiniowane
Numbers2=1,o,11,21,e,10,44,Zip1,Zip2,miastol,nic,panstwol,miastop,nic,panstwop

to w odbiorniku dostajemy sensowne opisy, choć "na sztywno" :-(

Agrykola 14
ZIP2 Miastop, Panstwop

Uwaga. Trzeba definiować numeracje dla każdego skrzyżowania/odnogi aby była poprawnie w odbiorniku.

A jak zrobić ruting?

Po prostu odpowiednio ustawiać kategorie drogi, pamiętając o:

  • Level0=24 (ponoć również 23, ale jednak nie do końca)
  • węzły różnych obiektów muszą się pokrywać (praktyka pokazuje że nie muszą, ale o tym ćśśśś)
  • kolejne węzły obiektu nie bliżej niż 6 metrów!
  • ronda muszą być z dwóch połówek, ale nie u nas w UMP.
  • warto optymalizować, tj. żeby jedna ulica nie była z fefnastu kawałków, bo to spowalnia wyliczenia
  • rutowalne sa typy dróg: od 01 do 0c (aleje i unpavedy też), 16 (trail), 26 i 27 (promy).

W ramach UMP-pcPL dane do routingu są tworzone (umplodz.republika.pl/netgen_en.html) netgenem za każdym razem.


Można też ręcznie (ale nie w UMP, technikalia, dla ciekawych):

  • Opisy są u Staszka.
  • dla każdej drogi trzeba dopisać RoadID=numer (od 1 do 16mln)
  • dla każdej drogi trzeba dopisać Routeparam=speed,class,oneway,toll,denials gdzie speed jest od 0 (prom) do 7 (autostrada),class od 0 (najmniej preferowana) do 4 (najbardziej preferowana) (teoria wymaga zbilansowania różnych klas, na razie nieważne) oneway=1 to jednokierunkowość toll=1 to droga płatna denials to osiem zer z przecinkami (zabraniają ruchu różnym kategoriom podróżnych, co komu to na razie nieważne) na przykład – sprawdźcie w źródłach
  • i najlepsze: każde skrzyżowanie ma mieć przydzielony odgórnie numerek unikalny dla mapy (od 1 do 104tys, ciekawe dlaczego mniej niż dróg). W którym miejscu ulicy występuje które skrzyżowanie, opisuje się tak: NodX=point0,skrzyżowanie,bound gdzie bound=0 chyba że to brzeg mapy i punkt łączy się z druga mapą (routing przez wiele imgów), na przykład:
Nod1=0,33,0
Nod2=4,34,0

znaczy: pierwszy punkt drogi to jest skrzyżowanie 33, zaś piąty to trzydzieste czwarte. Oczywiście w innej drodze któryś punkt też ma być tym skrzyżowaniem numer trzydzieści trzy..

No ale jak to wklepać? Można z pomocą MapEdit (opcja "Tools – Generate routing graph"). Można prawie automatycznie – służą do tego dwa programy: MapRoute Staszka, oraz netgen (umplodz.republika.pl/netgen_en.html) Mariusza Dąbrowskiego.

Jak taką mapę z rutingiem sprawdzić?

W MapSource. Albo w terenie z odpowiednim odbiornikiem.

Wszystkie możliwe testy (ślepe, przecięcia, za bliskie i zygzaki) możesz hurtem wygenerować uruchamiając sprawdz_bledy.bat.

Pliki wpt które tworzy to:

  • netgen-slepe.wpt - gdzie są ślepe końce (czyli potencjalnie nie dociągnięte porządnie ulice), często bardzo dużo punktów, można oznaczyć bojką zieloną 0x1709 jeżeli tak ma być.
  • netgen-przeciecia.wpt - gdzie nie ma przecięcia – być może wiadukt, a być może źle narysowane skrzyżowanie, jezeli jest wiadukt oznacz to czerwona bojką 0x1708.
  • netgen-zygzaki.wpt - gdzie są zygzaki (bardzo ostre zakręty - routing bardzo ich nie lubi) trzeba je rozciąć.
  • netgen-zabliskie.wpt - podobny do ślepych ale w pobliżu jest punkt do połączenia.

Pamiętaj o prawidłowym wpisie do setenv.bat/środowiska (netgen=...). i oczywiście dodając sobie te pliki wpt do mapki.

A zakazy skrętów, można?

Oczywiście, że tak – robiąc tzw. restrykcje: jeśli mamy dwie drogi o RoadID=A oraz RoadID=B, krzyżujące się w nodzie N, a chcemy wprowadzić zakaz skrętu z ulicy A z kierunku noda A1 w ulicę B w kierunku B1, to w dowolnym miejscu pliku mp trzeba dodać

 [RESTRICT]
 NOD=N
TRAFFPOINTS=A1,N,B1 TRAFFROADS=A,B [END]

[ uwaga – linijka Nod= nie jest już wymagana w wersji 0088 kompilatora, bo i tak zawsze mówiła to samo, co TraffPoints ] Owszem, można te ciągi punktów i dróg rozbudowywać, tworząc np. zakaz zawracania na ulicy dwupasmowej, czy nawet zakaz skrętu w lewo na rondzie (przykład: warszawskie rondo de Gaulle'a jadąc od Centrum).Praktycznie takie dziubanie jest strasznie żmudne, w dodatku przy kolejnej generacji mapy dostajemy nowe numery ulic i skrzyżowań, więc zastosowano sztuczkę – netgen zamienia linie określonego typu (u nas: time zone) na odpowiednią restrykcję. W źródłach umieszczamy np.

 [POLYLINE]
 Type=0x19
 Label=Jerozolimskie na zachod < kolo Smyka
 Data0=(52.23173,21.02021),(52.23096,21.01650),(52.23087,21.01655)
 [END]

Na co to się zamienia w kompilacji, to nie warto analizować – bo konkretne numery mogą się za następnym razem zmienić.Dodatkowo, od wersji 0088 kompilatora i 0.8 netgen, można dodać ręcznie ;-( linijkę

 RestrParam=1,0,0,1,0,0,0,0

i wtedy zakaz nie będzie obowiązywał busów i karetek. Znaczenie zerojedynek jest identyczne, jak dla RouteParam. Dla perwersów: możliwe jest również określenie czasu, kiedy taka restrykcja miałaby działać. Jeśli dotarłeś aż tak daleko, skontaktuj się ze mną.


Jak nazywać nowe pliki w cvs?

Trochę sama z siebie, trochę z przemyśleń i potrzeb, wykształciła się taka konwencja nazywania plików w drzewku cvs, które idą do przetwarzania: uwaga na DUŻE, one są istotne

  • katalog UMP-JakisObszar/
  • plik JakisObszar-big.mp (samodzielnie działający – jako forma przejściowa od UMP-PL do opisanych niżej)
  • plik mont-demont.bat (jednakowy dla różnych obszarów, ale powtórzony dla wygody)
  • katalog src/
  • plik cities-JakisObszar.pnt
  • plik(i) POI-*.pnt (w tym POI-routing.pnt)
  • pliki cities-JakisObszar.txt i POI-JakisObszar.txt – niewskazane, chociaż dopuszczalne
  • pliki MIASTO.ulice.txt (do zawartości dopisywana jest przynależność do miasta)
  • plik(i) inne.ulice.txt i *.drogi.txt (do zawartości nie jest dopisywane info o przynależności)
  • pliki *.zielone.txt
  • pliki *.woda.txt
  • pliki *.obszary.txt
  • pliki *.kolej.txt
  • pliki *.zakazy.txt
  • pliki *.granice.txt
  • pliki *.highways.txt (na zjazdy z autostrady)
  • pliki *.debug.txt (na znaczniki ślepych końców oraz wiaduktów)
  • pliki *.szlaki.txt (choć powinny byc przenoszone do UMP-szlaki)

Jak zrobić nowy plik na jakieś miasto? Zrobić plik (bez zawartości), potem cvs add nazwapliku i cvs commit. W przypadku wieloczłonowych nazw miejscowości pisanych z odstępem (spacją), znak ten należy zastąpić znakiem _ (podkreślenie). Nazwy pisane z dywizem (myślnikiem) zapisujemy w normalny sposób. Człony "Mazowiecki, Wielkopolski" itp. piszemy w całości. Przykłady:

BIELSKO-BIALA.ulice.txt
GORZOW_WIELKOPOLSKI.ulice.txt


Powoli budują się autostrady ze zjazdami. Jak to definiować?

MapEdit nie wspiera (?) wszystkich cech zjazdów. Trzeba dodać punkt z kategorii "Exits" (0x2000 – 0x273F), np. typu 0x2100 Exit with facilities, i ręcznie dodać mu parametry:

 Highway=nazwa (np. A4W)
 Label=nazwa zjazdu  (np. "Wrocław Wschód")
 Exit1=typ,kierunek,cechy,opis_uslug
 Exit2=typ2,kierunek,cechy2,opis_uslug2
 OvernightParking=1
 StreetDesc=opis zjazdu (np. numery dróg)

i dodać go do któregoś pliku *.txt najlepiej MIASTO.highways.txt. Poniżej spisy możliwych parametrów. typ to:

typ opis
0x00 przystanek 24h, paliwo, jedzenie
0x01 paliwo dla ciężarówek
0x02 paliwo
0x03 jedzenie i restauracja
0x04 spanie
0x05 naprawa
0x06 naprawa diesli
0x07 naprwa – myjnia płatna
0x08 kemping
0x09 szpital
0x0a sklep / automaty
0x0b park, las
0x0c ciekawy punkt / inna usługa
0x0d szybkie jedzenie

kierunek to:

kierunek opis
N na północy od zjazdu
S na południe od zjazdu
E na wschód od zjazdu
W na zachód od zjazdu
I po wewnętrznej
O po zewnętrznej
B po obu stronach

cechy to suma poniższych:

cechy opis
0x01 parking
0x02 sklep
0x04 paliwo do diesli
0x08 myjnia
0x10 LPG
0x20 waga
0x40 czynne 24h

...... FAQ dla zaawansowanych

-- Alf/red/

na podstawie FAQ z 2008/02/27 13:11:49

Also on Fandom

Random wikia